Shortcuts not working properly on Mac

Hello everyone. This is the first time I GM online and my plans were to GM an online ALIEN RPG game on November 1st. I have just purchased the Gold Membership but as I follow the tutorials I’m already worried that I might have chosen the wrong platform…
Many of the shortcuts that the tutorial gave me do not work properly or at all. I am using Firefox and tried to use Chrome, but on Chrome the website barely opens properly and the map takes forever to load.
Here are some of the problems I’ve found:

  • Shift+scroll for zooming in and out the Character Sheet: it works only for zooming out, not in, so I have to always use the double click.
  • Backspace to delete token: although the “delete” button works fine, pressing backspace crashes Astral and takes me out of the room after showing me a red warning box saying that there was a problem deleting the token.
  • Commant+click&drag to select group of tokens: doesn’t work at all… the pointer symbol changes accordingly, but there is no dragging square and I can’t select anything.
  • Comand+click different tokens to select as a group: doesn’t work as all.
  • Command+C/Command+V to copy and paste mobs: doesn’t really work… I managed to make one copy appear, and only one. All other cases I just tried with no results at all.

I really appreciate any help here. I have a little over a week to get things ready and if these issues continue I won’t be able to play! And I have payed for the Pro package already, so that would be a major problem.

I am using a iMac with High Sierra 10.13.6