Grid snapping problem

I am new and just acommodating with the functions of the program. So please bear with me if this post is already answered elsewhere.

I wanted to turn off grid snapping in one of my maps. The little info window right below told me that the gridsnap is now off. As I returned to the map, the token was still grid snapping. I tried it several times, but no change. still grid snapping, even after refreshing the window. Is this tool not working properly or did I oversee something? thanks for any info.

Hi @JOM

Grid snapping, as it currently works, only affects map assets. There is however a Feature Request for allowing snapping to be turned off for tokens as well. I’d suggest voting and / or commenting on that request.

thank you very much. thats a bummer, because grid snapping for tokens is essential if I want to use maps with my own grid on it or free form moving.

Turning off Grid Snapping for tokens has now been implemented.

// Closed as Implemented