[DnD 5e] Sheet doesn't render the pages

Hello everybody,

I’m trying astral for the first time coming from Roll20 and I’m finding it awesome, but I’m having problems with characters sheets. I created a characters without a problem, but the sheet page doesn’t show up on the character build menu.
Here’s some prints of my screen:

Character build screen:

Build character screen:

Build characters (pages):

The pages are shown on the menu, but they are not rendering on the character building and I really don’t know what is happening. Looking on my browser console i saw that two resources are responding a 404:

Can somebody help me? I really want to move to astral…

EDIT: I tested other sheets and the exact same thing happen, so I don’t’ think is a problem with the Dungeons and Dragons Sheet

Hi @bichodemasmorra,

Happy you’re here! Lets get this working for you so you can enjoy all of what Astral has to offer.

Off the top of my head, the most likely causes are:

  • Unsupported browser (namely Safari)
    • make sure you’re using Chrome, Edge, Firefox or OperaGX as they are our most supported browsers.
  • Browser add-on/extension incompatibility
    • Try an incognito/private browser tab, or a completely different browser with no 3rd party software installed. If it suddenly works, try disabling each of your add-ons/extensions and retesting until you find the one that was causing issues.
  • If you’re using Chrome, make sure Hardware Acceleration is enabled
  • If you’re using Linux, make sure Hardware Acceleration is enabled at the OS level.

If you’re still having issues, can you do me a favor and drop me a bug report from within the app itself? It’ll give me metadata that will be helpful in tracking down the cause of the issue.

Thanks for the response!

I was already running it on Google Chrome (Version 98.0.4758.109 (Official Build) (x86_64)) on a MacBook pro. I did the following:

  • I checked and my harware acceleration is on.
  • I uninstalled my google chrome and reinstalled it, so right now i don’t have any add-ons.
  • I tried running on incognito.

But it’s still not working.

When you said it could be a browser incompatibility I tried running Astral on Safari (the only other browser I have on my computer) and it worked just fine.

EDIT: I just reported the bug :wink:

Safari isn’t currently supported. Some parts of Astral run great, but other parts have severely compromised performance. I’d encourage you to use at your own risk, but don’t be afraid to switch out browsers if things go very wrong in Safari.

I reviewed the metadata, unfortunately didn’t provide me with the smoking gun I was hoping for. Just to toss this out there, are you able to load the character sheets using Firefox, Edge, or OperaGX?

I’m seeing a 400 permission error in characters and macrobar. It could be something related to authentication. Could you try logging out fully, then logging back in?

Are you running any sort of VPN, or are you on a network that has restrictions in content? This would be something like a college, military base or school.

I’ve had a couple more reports come through as well.

Everyone who’s been affected has been on MacOS X Catalina (10.15.7). There could have been another case of a Catalina security update that caused issues with WebGL-based websites like ours. Do you have the option of trying from a different device or updating to a newer version of MacOS?

Let me know if that works. Rest assured I’m on the case.

It looks like for those affected, using Firefox resolves these issues. It’s hard to tell why this occurred, but it may be related to an interaction between Chrome and MacOS Catalina.

I hope this helps, please let me know if this unblocks you for now.