Dice roller - Delayed roll seems to be broken

the simple example found in the docs
https://help.astraltabletop.com/advanced/syntax/
should provide a button on where to click, but, only the formula is shown in the chat and click on it just doesn’t trigger the roll, few weeks ago it worked fine.

Regards
Axel

Hi @Axel

Did you drop a bug report for the issue?

Did that just know, hope it get fixed soon

@Axel

I tested delayed rolls with my own sheets and they work correctly. Is it possible that you have a syntax error in your roll so that the system cannot roll it? If you do have an error the system will just show the entire formula without actually allowing you to click on it to roll.

Copy pasta from the documentation and even tried to use those from the forbidden lands provided sheet, on chrome and brave browser.

image
not clickable, does not render as a button, do not have aria-role button. Just show a tooltip telling me “roll not executed”

More information for your developers:
In chrome tools deleting the firebaselocalstoragedb and reloading the page do show clickable button but they do not trigger the roll, having to relog cleanly to use the app again.

Interesting… I’ve never thought of trying to do a delayed roll from the dice roller. It is normally reserved for Actions.

If you create an Action and then use the delayed roll in the Action, you should see the results that you expect.

Rolling in the chat window is designed to give an immediate result, so attempting to perform a delayed roll there seems counter intuitive.

It does not work from both actions and from chat input, what is strange that a week ago or so it did work fine. I can only guess there is something wrong in my profile data.

That is a possibility. As I mentioned previously, after I read your post I tested Delayed Rolls with one of my character sheets and it works for me.

I’m also having the same problem; delayed rolls are not executable (and yes, I bug reported it).
Everything was working fine before the new (beta) character sheets went live, so it’s not the syntax of the Actions.

Ok so we experience same issue

I can confirm that delayed rolls stopped working for me on the 19th and I posted a screen shot into the Beta Test group to report it. They stopped working in Actions and from the chat window, they stopped when the beta sheets went live.

Got a reply to my ticket everything seem to work fine.

1 Like

Thanks for the bug reports! We have resolved this issue, if anyone else is experiencing it, please drop us a bug report and I’ll investigate.

1 Like