Astral slow in Chrome just for me

Hey there! I’ve been having an issue for the last few months with Astral in Chrome. It’s really really slow for me, but not for my friends who are also using Chrome. This happens for me even when I create a Chrome profile with no extensions and enable settings to allocate more resources to Chrome from my OS. However, I have no issues running Astral in Edge. Here is a short video of me explaining this issue!

If anybody has experienced this and has any advice, I would be very thankful =)

A few of my friends are experiencing this too now, it seems!

It seems that Google have made some or other change to the Chrome browser recently causing slow downs to the WebGL processing.

I highly recommend trying Microsoft Edge if you are willing. :wink:

Thanks for the reply! Yeah, I’ve been using Edge for a few months with less issues. I think some of our map animations don’t work on Edge, but that’s still miles better than the current Chrome experience for me.

If you are using Windows 10 or 11, make sure that your browsers are set to Performance mode in Settings / System / Display / Graphics. That should help with animation issues.